Sage Enterprise Intelligence compatible with sage 300 2014?

Hi,

We are currently on version sage 300 2014 and would like to look at Sage Enterprise Intelligence. Does this work with our current version of sage?