Connection to database error

We are consistenly getting an error regarding the connection to the Timeslips database.  When one user is connected, the others cannot access the database.  Once that user exits, another user may connect.  It does not seem to matter which user is connected first.  Support said that I need to check the connection from the software to the timeslips.cfg file on each computer running the main software.  However, the condition described above seems to imply a different issue with the connection, and I believe that all of my users are conencting through the terminal server to the main program.  We had an issue with licenses not being cleared, but I implmented the batch file script from support used to clear the licenses, and that issue seems to have been solved.  Not sure if the two are related.  Please advise.  The text of the error is as follows: 

 

Another program is accessing your Timeslips database in a way that prevents you from accessing it.

Check for these causes:
1. The file paths to each installation folder must look the same except for the drive letter.
     I:\Timeslips and J:\Timeslips are the same. I:\ and J:\Timeslips are not.

   If one of the stations is the server, it may be the culprit. It must use the same file path as other stations.

   On each computer, check the Installation Folder in Help; About.

   Use the Change Install Path command in Station Administrator on the computer that has a different file path.

2. Timeslips is installed in multiple locations. Only one installation can access a database.

3. A non-Timeslips program is using your database.

4. Run Station Administrator's Diagnose This Computer command for additional diagnostics.

Area: Table
Code: 126
Address: Exception tBDETableExceptionC in module Timeslip.exe at 0092E203.


Version: 17.0.2.0481
Table: General Setting
Record: 0
BDE Code: 11270

 

Thanks

 

Parents
  • I just tried correcting the path to the Timeslips.cfg file through the Station Administrator, which seemed to be pointed in the wrong place since it opened the wrong directory, intially.  Anyway, correcting this did not seem to resolve the issue.  There is an API license open that does not clear using the aforementioned script.  I wonder if this is the culprit?  Any help is appreciated, thanks. 
Reply
  • I just tried correcting the path to the Timeslips.cfg file through the Station Administrator, which seemed to be pointed in the wrong place since it opened the wrong directory, intially.  Anyway, correcting this did not seem to resolve the issue.  There is an API license open that does not clear using the aforementioned script.  I wonder if this is the culprit?  Any help is appreciated, thanks. 
Children
No Data