Sage 50 v27 - Excel Ingregation - Refresh no longer working

Hi.

I've recently upgraded from v26 to v27 and reinstalled EIR as instructed.

If I generate a new report in Excel, it works fine, so I think the data links are ok.

However, if I click on 'Refresh' to get updated data, after a few seconds thinking time, I get an 'Error Executing Report' error box with the unhelpful message 'One or more errors occurred.'

I can't get a single report to refresh.

Any suggestions?

Many thanks, Ian

Parents
  • Sage is running on a standalone PC with no networking and no other users accessing the data - software and data are all on the PC hard drive. I can't quite fathom how I was able to run a new excel report in v27 (see original post) if there was no data service running. I also do not know how to start, restart or otherwise change the data service - this has always been automatic on all previous versions up to v26

  • The network stack is technically still involved even though you are running the the application and dataservice locally. In terms of troubleshooting the only thing that running locally likely takes out of the equation is the firewall blocking access.

    The data service does run automatically under normal circumstances, and this has not changed for v27, but one of the possible causes of the error message you are getting is if the service were stopped for some reason (deliberately or accidentally). This is why I was suggesting checking that the data service(s) are running just in case.

    To check if you go to your start menu and type services.msc you should see the Services app. Launch that and look for and  services called 'Sage 50 Accounts Service vXX' (where XX is the major version number of the Accounts application(s) you have installed). In the status column it should say 'Running' if the services is active. Check this for all versions of Accounts Vs the versions of the data files you have on your PC. It is possible,for example, that you have v26 data files but do not have a v26 dataservice running because the v27 application was installed as an upgrade rather than side by side.

    If you are still having difficulties then your best bet would either be to wait for the v27.1 release that addresses your original refresh issue or to install the legacy version of Excel Integrated Reporting that I mentioned above as this does not suffer from the refresh issue.

    Hope that helps.

Reply
  • The network stack is technically still involved even though you are running the the application and dataservice locally. In terms of troubleshooting the only thing that running locally likely takes out of the equation is the firewall blocking access.

    The data service does run automatically under normal circumstances, and this has not changed for v27, but one of the possible causes of the error message you are getting is if the service were stopped for some reason (deliberately or accidentally). This is why I was suggesting checking that the data service(s) are running just in case.

    To check if you go to your start menu and type services.msc you should see the Services app. Launch that and look for and  services called 'Sage 50 Accounts Service vXX' (where XX is the major version number of the Accounts application(s) you have installed). In the status column it should say 'Running' if the services is active. Check this for all versions of Accounts Vs the versions of the data files you have on your PC. It is possible,for example, that you have v26 data files but do not have a v26 dataservice running because the v27 application was installed as an upgrade rather than side by side.

    If you are still having difficulties then your best bet would either be to wait for the v27.1 release that addresses your original refresh issue or to install the legacy version of Excel Integrated Reporting that I mentioned above as this does not suffer from the refresh issue.

    Hope that helps.

Children
No Data