Sage X3 Security Update

In April we were alerted to a security risk in Sage X3 that may impact customers using on premise ONLY versions of Sage X3, Sage X3 Warehousing and Sage X3 HR & Payroll.

The security risk is related to a platform component and has no impact on the Sage X3 application code or customizations that may have been implemented. 

Impacted Sage X3 Versions:

All on-premise and hosted versions of Sage X3 may potentially be impacted by this vulnerability, including Sage X3 Version 9, Version 11 and Version 12.

Sage X3 Version 12 2021 R2 is not impacted by this issue.

This does not affect Sage managed Cloud versions of Sage X3.

Security FixCompatibility:

The security fix has been made available for all versions that are in support as per the Sage X3 Lifecycle Policy at March 2021.

Customers on older versions that are not supported and who have valid maintenance contracts, are strongly advised to move to supported versions and install the security fix as soon as possible.

For Sage X3 Version 12, the security fix is compatible with all versions from 2020 R1.

Please note that for versions 2020 R1, R2 and R3 along with the technical components specific applicative patches are also required.

These technical components are included by default from 2021 R2.

The security fix was provided on the 27th of April and is available on our Sage ftp site.

For more information click on the links below. If you are unable to open the links please visit our Sales or Partner Hub portals.