Sage X3 V11.0.18 is now available

Mandatory components:

  • Syracuse Server 11.23
  • MongoDb 4.0.18

Recommended components:

  • Console 2.47.0
  • Print Server 2.20
  • VT Web Server 2.38.10

The patch and setup media are available on our Sage X3 ftp site.