• Sage Exchange 1.0 is not longer supported by PAYA

    • Sage Exchange 1.0 is no longer supported by PAYA or Sage Daceasy.
    • Sage DacEasy Users need to upgrade to Sage DacEasy 2015.1 and be on a BC plan
    • Then after upgrading Install Sage Exchange 2.0 which only works with Sage DacEasy 2015.1

    ALERT: Sage Exchange…