Announcement!
This is a notification for product news or an alert. If you have a question, please start a new discussion

Important information about Sage 50 US version 2020.1 and earlier

This post only applies to you if you are using Sage 50 version 2020.1 and earlier.  

In order to utilize the most current TLS (Transport Layer Security) protocol recommended by third-party standards organizations, you must be on Sage 50 US Accounting version 2020.2 or later by September 30, 2022. After that date, you will be unable to install and automatically reactivate version 2020.1 and prior versions of Sage 50 US Accounting. Because of this, we strongly recommend you upgrade to the latest supported version (2022.0) of Sage 50 to receive critical security updates relating to this protocol that better help protect your data. If you are using Windows 7, you may need to perform additional steps. Please refer to the following documentation from Microsoft: Update to enable TLS 1.1 and TLS 1.2 as default secure protocols in WinHTTP in Windows.

If you are on an active plan, the latest version can be downloaded by accessing Sage 50—U.S. Edition: Download Portal.

If you are not on an active plan, please contact Sales at 877-495-9904 to purchase the latest version of Sage 50—U.S. Edition. Sage Accountants Network (SAN) members, please call 866-565-2726.

Note: If you have already purchased the latest version but do not have your serial number, please refer to What is the serial number for my product?