_AGETADPTYP Error upgrading from 9.0.3 to 12

I am going through the 'quick' upgrade guide to migrate a test environment from 9.0.3 to 12.0.15. I get through applying the license in Syracuse, then I log out or restart, but I get the following error logging in and launching X3 functions. (I'm in the X3 folder so I can save and validate my child folders). I tried using the Syracuse from 12.0.14 and 12.0.15, and it made no difference. The consequence is that it won't load the site map beyond the 'Administration' menu, and none of the X3 functions work. (Although GESAUS did work once.) I have some favorites, and I did upgrade the supervisor via launching GESAUS, although there were errors when it finished. I also tried applying Patch 15, then selecting only the X3 folder, and that didn't make a difference. I will note that there is a KB article (95163) that discusses this error, but the cause is that the client's versions of SQL Server Management Studio weren't all the same. I only have one version, and that doesn't make a great deal of sense to me anyway.

When logging in:

Sitemap loading failed
X3 engine error: _AGETADPTYP : Non-existent Label

X3 engine error:
@X3.TRT/ASYRMAIN$adx(160):(No Label)

Launching GESAUS:

@X3.TRT/ADOVAL$adx(1260) :
@X3.TRT/MENU$adx(208):(No Label)

Parents Reply Children
No Data
More Content