Crystal Reports

I am having an issue with a workstation

new Windows 10 computer, installed the Mas500 2019 client

When the user tries to run the Aged Receivables, he gets an error

              "crystal print engine the system cannot find the file specified"

I have reinstalled the 2019 Client

I have reinstalled .net 3.5 and .net 4.8

I have installed the crystal reports engine

I have installed the CRforVS redist

I can't get the report to work on this workstation

  • From Sage 500 Knowledgebase article  94251  "Error: "OpenCrystalPrintEngine -2147024894; Automation error The system cannot find the file specified" when trying to preview/print reports"

    Resolution:

    If runing Sage 500 verion 2018 or higher, try the following.

    1. Close and shutdown the Sage 500 Desktop
    2. Right click the Sage 500 icon and select Run As Admnistrator to launch the application.
    3. Login and try to reproduce the reported error

    Try running the steps from the article under Related resources entitled "Crystal Configuration Utility"

    If you are still getting the error after following the steps above please contact Sage 500 Technical Support  for further help.

  • I just downloaded the Crystal Configuration Utility.  I have tried the other options so far.

    Thanks

    Joe

  • Joe: Did you already check the application.config file in the "C:\Users\<user name>\AppData\Roaming\Sage Software\Sage MAS 500" folder to confirm the <ReportPath> setting for the user? This ReportPath setting defines the parent-folder under which the 500 software looks for each module's \Reports folders containing the standard Crystal reports *.rpt files.

  • Other reports were working.

    I downloaded the Crystal Config Utility.  and it seems to be fine now.

    Thanks for the help!

    Joe