Sage CRM 2019R2 with Sage 300 2020PU1

Hi all,

Just upgraded a customer from Sage CRM SP3.4 to Sage CRM 2019 R2 (went through to 2017 first and then to 2019R2) and integrated with Sage 300 2020 PU1

This customer is a lil' bit upset and wants to go back to 7.3 (!)

Issue 1

In 7.3 integrated with Sage 300 2017, they were able to convert a lead to an opportunity and create a OE quote and the address of the company would port over to the quote. CRM 2019 does not do that. Spoke with CRM tech for over 2 hours and finally they said it was by design.

Issue 2

In 7.3 with Sage 300 2017 integration they were able to copy and paste a blurb of item details in the comment/instructions field of the item line on a quote. Now the system wants them to enter the details line by line.

It was suggested to me to email the product manager to see if changes can be made.

Any one of you run into these issues? What would you recommend?

Thank you

Prabha

  • I may not be much help as we don't work with Sage 300 2017, we integrate with Sage 300 CRE which does not integrate out of the box.  With that said, regardless of the integration, I will see if I can help answer your questions. I am not aware of significant changes between 7.3 and 2019 for quotes.

    For Issue #1, I am wondering if it could be related to screen setup.  In my system the address does come from the company when creating a quote.  There are two addresses on the screen, a billing address and a shipping address.  The box below each of the addresses lets you change these any company address.  I would check and see if these fields are on the screen.

    For Issue #2, I don't have 7.3 on my system to see what they might have been doing in 7.3.  However, it sounds like they might have been using the "Free Text Item" which would allow them to type what they wanted.  You can see the button highlighted below and then the box that comes up when clicked.

    Free Text Box

    Hope this helps!

  • Hi, can you take some screen shots and post them on here of the screens in crm you are referring to. 

  • Hello Daniel. See below.

    Address issue.

    - I have a lead where I have entered the address

    - I convert that lead to an oppo and then generate a quote from that oppo:

    Lead:

    Here is the company the lead is matched to and I have the address in there:

    Here is the opportunity linked to that company:

    I do a quote:

    Since this is a lead and not yet a customer in the ERP system, we are assigning a generic customer number: CRM99999999

    If you click on the 3 bars next to "Customer Number", you can access the "Customer Bill to address"

    But it is all blank

    I understand why it would be blank if I was doing a quote directly in Sage 300 ERP but from Sage CRM since the system has the address from the company setup in CRM, it should default to that address. No?

    Why would we make users have to re-enter the address again?

    Comments/Instructions issue

    Users were able to just copy paste a blurb before in the comments column of the line item on the quote/order. So say I want to copy some specs:

    I have to 1. click on "add line" first:

    When I copy and paste my blurb in, it only copies the first line

    Now I have to click on "add line" again and add the second line only and so on and so forth.

    Not very user friendly. User needs to be able to paste 250 chars in here in one go - not line by line - like a memo field?

    Thank you

  • Hi Michelle,

    I posted some screenshots below. There is no "free text box" in Sage CRM 2019 or the webscreens. Might be something that you customized.

    Thanks!

  • I think it may be worth investigating how addresses are brought across from Leads. 

    For example

    If the Lead is matched to an Company but the Lead Contact is 'new' then the address in the Lead is associated with the person and not the company.  

    If the Lead is for a previously unknown Company (and Contact) when the new Company is created the Lead address becomes a company address.