Sage CRM 2020R2 y Exhange365

Hola, buenos días.

Despues de configurar el Exchange, el Azure Active directory y el Sage CRM tal y como dice este manual:

https://help.sagecrm.com/pdf/2020R2/SageCRM_2020R2_ReleaseNotes_ES.pdf

No me funciona tengo estos errores en los buzones:

ERROR [http-nio-10002-exec-3]: 30-nov-2021 16:39:53.862 [xxx] error: User [email protected] excluded from synchronisation processing - no primary SMTP address found, action: CONNECTION_TO_MAILBOX

Alguien puede ayudarme por favor.

Gracias. Un saludo.

  • Hi PereRojas

    Microsoft did announce that they weren't going to disable the original method of authentication** in Exchange 365. So try configuring CRM to use Exchange Server and use the original URL

    https://outlook.office365.com/ews/exchange.asmx 

    And see if that still works for you. 

    ** The actual message from Microsoft was that users who were using Basic Authentication would still have it enabled, but those who weren't by a particular date (was suppose to be Oct 2021) would have it disabled. But via a support ticket they could request for it to be re-enabled. 

    They're supposed to be working on a method to add to the Admin Controls the ability for Administrators to be able to enable/disable this themselves. 

  • Hola, buenos días.

    Gracias por respoder.

    Es lo primero que prové pero decía que no me encontraba el servició, Sage España me dijo que era normal que lo tenia que configurar como Exchange365 y me encuentro con este problema. Y Ahora Sage España no encuentra ninguna solución...

    Tambien he mirado este video i lo tengo toto correcto.

    https://www.youtube.com/watch?v=XQlX5gVeLgs

    Gracias.

  • This is working perfectly for me

    The only thing I did in Exchange365 is to set up a user account to have the ApplicationImpersonation role added to them. 

    If this doesn't work for you, you might need to raise a support ticket with Microsoft and see if Basic Authentication is enabled. 

  • I'm a bit slow to Microsoft message and just see that from October 2022 they will be disabling Basic Authentication in Exchange 365. So it looks like you will need to swap over to OAuth2 at some point anyway. 

    I'll have a got at setting it back up in my virtual machine and see if I can getting it working again. 

  • Hola, buenos días y gracias por contestar de nuevo. esperaré su prueba a ver como va. De momento tengo la incidéncia abierta en Sage España. Un saludo.