Sage CRM 2018 R3 Issues with Lead Add or Find this Company when Deduplication is set to Yes

When working with a Lead record and matching a company to the Lead via the Add or Find this Company button. The system is supposed to open a pop up that displays a list of potential company matches, which you can select from, and everything happens within the popup, until finally clicking Select Company which closes the pop up and refreshes the Lead.

However, with Deduplication turned on in System Behavior, when selecting Add or Find this Company button on a Lead, instead of it automatically displaying the results, the pop up has the Company deduplcation screen, with the company name search. If you search for a company, and then select from the list, it opens the company in the main screen, and the Select Company button doesn't work, because obviously the system shouldn't have behaved this way to begin with.

In system behavior if you set Deduplication to No, this issues doesnt happen, but then you lose dedpulication in other areas.


Has anyone else experienced this bug, reported it, have a resolution?

Thanks

Parents Reply
  • Followup on this post...

    I have used this for CRM 2018 R3 and it worked successfully.  For the client we used this on, they will be upgrading to CRM 2019 this month.  I see in the above post that users were experiencing issues with CRM 2019 as well.  Has this been resolved?

    Also, do we need to remove this script when the upgrade is completed?

    Thank you!

Children