This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Cumulative Patching - EasyUpdate - 2019R5 (V12P20) - Importante!

Sage X3 2019R5 (V12P20)

--- IMPORTANTE: LER! ---

Esta comunicação contem informações muito importantes sobre a mudança de metodologia de integração de patchs standard na V12 e alteração do Runtime.

 

1 - CUMULATIVE PATCHING - EASY UPDATE

Esta comunicação é sobre a nova forma de atualizar o Sage X3 V12. Por favor, ler o documento em anexo antes de proceder à integração da patch 2019R5 (V12P20).

Se a sua instalação está com 2019R4 (V12P19) ou superior, é mandatório usar a função de Easy Update (Administração > Atualização > Atualização) para efetuar a atualização da sua instalação.

Se a sua instalação é anterior à 2019R4 (V12P19), então primeiro é necessário atualizar para a 2019R4 (V12P19) e só depois atualizar para a 2019R5 (V12P20) ou superior, usando as instruções presentes nesta comunicação e no documento em anexo.

Cumulative Patching com Easy Update é uma nova metodologia de atualização do Sage X3 V12 que usa um catálogo de patchs (Patch Catalog) que otimiza a forma como é atualizada uma intalação X3 V12 para uma determinada versão (numa patch única).

Ou seja, se estiver na 2019R4 e desejar atualizar para a 2020R3 (por exemplo), já não necessita de integrar todas as patchs intermédias, bastando integrar a ultima versão disponível. Caso a instalação seja inferior à 2019R4, é mandatório integrar todas as patchs intermédias até à 2019R4 e depois integrar para a versão mais atualizada.

 

2 - Novo RUNTIME 92

Com a patch 2019R5 é entregue uma nova versão do Sage X3 Runtime com alterações importantes. Importante ler documentação antes de efetuar a atualização do Sage X3.

Com o novo Runtime são entregues as seguintes melhorias e correções:

  • Possibilidade de compilar scripts grandes ("Error 128");
  • Possibilidade de criação de indices de tabelas que referencam colunas além da 256ª posição;
  • Importante: alteração do formado .adx (tratamentos compilados);

Assim, um script (.adx) compilado com a nova versão do Runtime 92, não pode ser executado numa instalação com uma versão anterior do Runtime. É mandatório efetuar a instalação do novo Runtime 92 com a atualização do Sage X3 2019R5 (V12P20), visto que a patch já contem os scripts compilados com o novo formato do .adx.

Ver comunicação: https://suportemm.sage.pt/hc/pt/articles/360011035980