External link flags are out of sync

Has anyone had this error? Sage 50 V27 error "external link flags are out of sync" It pops up on one or both of our companies each morning?

Checking the data then running the repair fixes it, but this has to be done on the main computer, and with people working remotely, they can't do it.

Any advice would be appreciated.

  • yes we have the same error so would be interested to hear why this is happening and how to resolve it

  • Hi, I spoke to Sage via webinar today about this. They weren't aware of it but told me a version 27 patch is due imminently. 

    I've been trying a few experiments today and it seems like the error can occur during the day, but seems to only affect remote workers, especially if they are switching between companies. 

    I have had a couple of instances where a remote computer kicks the user out of Sage and when they try logging back in, you get the message Sage wasn't closed properly, do you want to check for errors? If you click no, Sage hangs and possibly may need to be reinstalled. 

    If you click yes it will discover errors, however if people are working at the main site, they would have to check for errors there and correct them. Then everyone would have to log out of sage so the remote user can log back in and check for errors.

    This seems to be a way around it, but it's not ideal.

    Hopefully this imminent patch will correct it.

    Simon

  • Hi

    I am a Sage developer and I have had this issue on a program that I recently upgraded to V27

    Sage Developers have confirmed that is a bug in V27 and they have reported it to R & D 

    When it will get fixed no-one knows but the more pressure that you can put on Sage the better.

    It seems V27 is a bit of a cockup all round

  • Hi All,

    I can confirm this is logged as a bug with our Product Delivery team. This issue was logged on the 9th of November to be investigated, the current workaround is to run check data and run the repair tools but I understand this can be frustrating.

    We currently have steps to recreate this issue when a third-party program uses documentlink function as part of SDO (Sage Data Objects).

    I'm not able to confirm when this will be fixed as v27.1 is due for release shortly but there may be time yet that we can still get it in (Depending on how complex it is to fix and test), if not it will likely go into v27.2

    Hope this information helps.

    If this has answered your question please click More > Verify Answer.

    Regards,

    Ian

  • Hi,

    I wanted to give an update on this error following our investigation within Product Delivery.

    This reply is aimed at third-party developers. If you're getting this error and using third party software that links to Sage 50, please refer them to this response. 

    I’ve looked at the Sage50 code, and the transaction post routines work fine.  If the link flag is enabled on a header, any splits will have their link flags set and in reverse, any splits which have the link flag set will update the header link flag. 

    The SDO test code supplied within the help guide doesn’t use the post routines, all it’s doing is reading a split record, setting the flag, and writing the record back out.  It never uses the transaction post routine, so the header flag will never get set which results in the error in check data.

     

    If you want to set a linked file on an existing split, then the test code / third party software needs to be updated to set the flag on both the split and the connected header.  

    If the developer is using TransactionPost to create splits and headers, and the link flag is set on the header or the split, that should be fine, as the Sage50 transaction post routine would set the link on both the written header and splits.

    Hope this information helps.

    If this has answered your question please click More > Verify Answer.

    Regards,

    Ian