Access Is Denied message in Sage 200cloud


We've had reports of an error "Access Is Denied" from numerous clients within Sage 200cloud.  Common theme is that they are all running a version of Sage 200cloud.  Doesn't seem to be reported on versions prior to cloud.

For a period we even got the message on our test VMs but it inexplicably dried up and hasn't happened for a while.  However, customers continue to report it.

Normally, logging out of the program and back in gets around it.  Typically, but not exclusively, the error will occur following the attempted display of a list view.

It's an issue that has been causing us much frustration as to what the cause may be.  Does anyone else have any experiences to share re. this error?


  • 0

    i've had a customer mainly getting the error on accessing the spooler but also on raising journals.  Mainly on 1 pc.  We switched off the option for the PC to sleep (as it was a laptop rather than desktop) and the errors seem to have greatly reduced.

  • 0 in reply to Gary Butler_1

    Cheers, Gary.  I'm not sure if that's been considered so will check it out.

  • 0 in reply to Richard Cunningham

    No worries RIchard, hope it helps!

  • 0 in reply to Gary Butler_1

    Hi Gary, I was able to reproduce the issue on the spooler after putting power settings in place.  I still can't reproduce the error in list views as our customers experience but this is certainly progress.  Many thanks. 

  • 0 in reply to Richard Cunningham

    Not sure if this will help or not, been having a little look on my VM to see if i could come up with something inspirational, but just ended up with some ideas that may or may not be involved. 

    Going between lists in 200c continually looks at the following registry entry: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\ShowEncryptCompressedColor - so my thoughts are with this - are any of the user profiles/temp files/IE temp files folders compressed or encrypted?  On Windows 10 its either two blue arrows on the icons in the top right or a yellow padlock in the same place.

    Other than that, it seems to mainly do things with the users temp files and IEtemp files, so i'd imagine you'd have already cleared the temp files and deleted browsing history but that maybe connected.  Other than that, it might be down to the Sage R&D developers to maybe make a suggestion as it possibly could  be .net, css, js as they are all referenced in a trace too.

  • 0 in reply to Gary Butler_1

    We have quite a few customers with this error message,  same screen movement as Richard really so going into list views accessing orders.

    we tell the clients the standard stuff remove temp etc which resolves for a short while before it comes back.

    we just cant pinpont the cause Disappointed

  • 0

    Sage need to come up with a documented solution for this, rather than trial and error at moment, ie one solution suggested has been to check the Network Adapters settings on the Workstations to disable any low power config.  Users did not have these issues in v2016, the issues have only occurred since 200c was released and they find it very frustrating when changing companies.  The issue normally happens if user leave their workstations for a while such as going to lunch ...

  • 0


    I have 3 customers reporting this, only one pc per site.

    We have been through the usual profile/temp files clean ups, anitvirus, IPV6, make sure its only connected by one network connection. But the problem persists.

    Whilst playing around and looking at the IIS logs for sage 200 services i found some entries around the time I could see in screen shots of the errors, There seemed to be a sequence of "session has expired" repeated a few times then "Access is denied".

    I then found in the logs in the users\appdata\local\sage\sage200 folder these errors were repeated in the desktop log.

    Here is a snip

    2019-08-13 14:13:34,159 ERROR 0 Sage.MMSAdmin.DBLayer.SessionManager ValidateSession, Session not found
    2019-08-13 14:13:34,159 ERROR 0 Sage.MMS.Admin.SystemAdminClientService.SystemAdminClient Sage.Common.Exceptions.SessionExpiredException: Session has expired. Please close the application.
    at Sage.MMSAdmin.DBLayer.SessionManager.ReportError(String message)
    at Sage.MMSAdmin.DBLayer.SessionManager.ValidateSession(String sessionID)
    at Sage.MMSAdmin.DBLayer.SessionManager.KeepSessionAlive(String sessionID)
    at Sage.MMS.Admin.SystemAdminClientService.SystemAdminClient.KeepAlive(KeepAliveRequest request)
    at SyncInvokeKeepAlive(Object , Object[] , Object[] )
    at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
    at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
    2019-08-13 14:13:34,174 ERROR 0 Sage.IdentityModel.Claims.Sage200.WCFServiceClaimsAuthorizationManager WCFServiceClaimsAuthorizationManager.CheckAccess ACCESS DENIED: Res=tobydesktop.microssit.local:10443/.../SystemAdminClientService.svc , Act=ISystemAdminClient/DisconnectCompany
    2019-08-13 14:13:34,174 ERROR 0 Sage.MMS.Admin.SystemAdminClientService.SystemAdminClient System.ServiceModel.FaultException: Access is denied.
    at System.ServiceModel.Dispatcher.AuthorizationBehavior.Authorize(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

    i have found this behaviour in all three sites in the IIS loging and the Desktop logging.

    I have not told sage this yet.

    I can also kind of replicate this at will but i have to use cheat.

    I do development as well as support, and when I develop and test my bespoke, I don't run the bespoke through the Sage 200 Desktop, I have a launcher program that connects me to sage 200, and then run sage forms from there. This makes it very easy to debug the code. What I have noticed a while ago was that if I am debugging code and I create a break point, or hit a bug in my own code that causes execution to stop (unhandled exceptions are good for this), if I then leave the application effectivly running, but stopped at the break point for about 30 mins, when I come to close my bespoke, I will get a "type initializer" error when my code tried to disconnect from Sage. Now after upgrading to 2018, the error no longer says "type initilizer" it says "Access is denied", and I get the same entries in the IIS log to do with Sessions expiring and Access Is Denied.

    I have several thoughts about this whole thing, and one is that this issue that is now being surfaced as an "Access is Denied" message has been there for a long time, but sage has swallowed it and dealt with it, now sage have changed something that is now surfacing the message out. Part of me thinks it the new logging they have done that is ironically causing the message to be surfaced.

    Anyway to me it looks like the connection from the client to the IIS webservices is expiring, eihter because the program has halted, or the keep alive heartbeat is not happening, this then causes an access is denied message when the client tries to make a call to IIS webservices.

    I have not taken this to Sage support as of yet, mainly because as soon as i mention the bespoke side of it, i suspect they will ignore the rest and try to push me to development support!!

  • 0 in reply to Toby

    Thanks for sharing, Toby. What precisely would you log with Sage as the issue?

  • 0 in reply to Richard Cunningham

    I would probably go down the route of showing the log entries, wander down the Web services rabbit hole, and take it from there. then if i could spark interest i would bring up the bit about my developer experience.

    i would be interested if others are getting the same log entries.

    I'm off next week, so will probably have another stab at garnering some support interest when I return.

  • 0

    We have also experienced this issue frequently for our clients recently, not necessarily when accessing list views though. We have found on 90% of the cases that the network is going to sleep to save power.

    To fix this we go into the network and internet settings > properties > configure > power management and then make sure the box is NOT ticked to 'allow the computer to turn off this device to save power'

    Hope this helps.

  • 0 in reply to Kelly Hardy

    I am only trying to save the enviroment, but it obviously takes me a long time to make a cup of tea.  Happens for clients and in house on all versions including 0035.  I can live with the log in log out, but do find it personally very annoying. And it is anywhere, changing company, lists, trying to get forms up to use.

  • 0

    Hi All. Experienced this on a client today. On each test when loading 2nd/3rd list view I received "Access is Denied" In the example I had it was nothing to do with Sage 200 which was fully and correctly installed (even though for the life of me I could not prove it) The issue in this example was caused by an application called "Carbon Black" (not easily visible and only surfaced when I said "Sage is right something must be going on" This application was scanning server changes (similar to Anti V but sending them to a cloud service) and locking the files during scan hence regular but intermittent "Access is Denied" on list views. Sage was fine, anti-v was fine,, permissions were fine but the application was locking files causing hangovers in appdata which were resolved by log out and in. Asking the 3rd party software provider to set Carbon Black to "bypass" resolved the issue after a day trying to fix something that was not broken. IN this case the only other symptoms I could provide were "Access is Denied" in Windows event viewer that were not even related to 200 (indeed no 200 symptoms in event viewer) Sage 200 was fine and essentially showing symptoms caused by Carbon Black. In other sites these could be similar because "Bypass mode" resolved all issues instantly 

  • 0

    has there been any progress on this? still happens on 2020 R1 on my vm

  • 0

    Has anyone else had any luck diagnosing this? My company has been having this issue since upgrading to 200cloud back in october 2019 and still haven't found a solution.

  • 0

    We still get this message on numerous sites, did anyone ever get anywhere with a solution?

  • 0 in reply to Toby

    Toby,  Did you get anywhere else with this?  We have a customer who is experiencing this issue constantly and it seems to stem from them leaving their PCs for a length of time.

  • 0 in reply to MikeNeville

    Hi, never had any serious investigation by Sage because its so hard to replicate, and then get them to look at.  It seems mostly linked to inactivity, as you have noticed.  So we usually try and get IT to look at powersaving, particularly, some powersaving settings on network adapter in the advanced settings. but it his and miss if you have the setting available.

  • +1
    verified answer

    Hi Richard/Everyone,

    Apologies for the late message on this one.

    It is something we have seen and had reported from time to time by certain partners and has been logged as an issue internally (currently only a handful of contacts). This was due to the fact we couldn't replicate at will or have replication steps provided which would always produce the issue, from our testing and troubleshooting on previous cases it seems to be something environmental as suggested in some of your comments, we have provided the suggestion of check power saving settings in the past and kept details of the contacts who have raised this via the support channel. 

    The most common cause we've seen is when users have left the system open overnight or a virtual machine in a saved status with the 200 program open will likely produce the issue if left long enough. Can I suggest that if you are still getting reports from customers around this, please raise a case via case management referencing this problem and i'll add the customer as a contact to the internal issue, this will help give us more insight into how big of a problem this currently is and we can then take a further look with more data available to us.

    Please raise the subject with 'FAO Paul R Access Denied' if you can then detail the below 

    - Which version of Sage 200 are they using
    - How often it is occurring
    - What troubleshooting has been attempted
    - Which client OS and Server OS are being used

    Kind regards,


  • 0 in reply to PRobinson

    Thanks for engaging, Paul.  I have shared your update with the team.  

  • 0 in reply to Richard Cunningham

    Hi, Just to add from our experience that most of these errors are remedied by:

    Elongating the power saving/ hibernation plan timer to allow more idle time for the user such as an hour to accommodate their lunch, or setting it to never.

    Additionally, within Device Manager > If the network card has the option "Allow this device to put the machine to sleep" then ensure this is unticked.

  • 0 in reply to Stu Mc

    Same as what Stu says really, the thought here is that it is due to Sage needing reauthentication to the network after the pc going to sleep or disconnecting from the network due to inactivity around it, etc.