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HOW TO STOP YOUR CHARTS
FROM DISAPPEARING

Have you ever experienced your Excel charts disappearing when you hide the columns
showing the data? By default, Microsoft Excel shows only visible data in a chart. In this tip,
we will show you how to easily overcome this problem.

3. In the "Select Data Source" dialogue box, select "Hidden and Empty Cells" in the bottom left
hand corner.

1. First, let's create a simple chart with your data to demonstrate.

4. In the "Hidden and Empty Cell Settings" dialog box, check the box "Show data in hidden rows
and columns".

2. If you had to hide columns A and B, your chart will disappear. To prevent this from
happening, click anywhere on the chart and from the ribbon, select Chart Tools > Design
> Select Data

5. Select "OK" twice.
Now, go ahead and hide your data. Your chart should still display with the hidden data!
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TO AUTOMATICALLY
02 HOW
HIGHLIGHT SPECIFIC DATA
USING A BAR CHART

This Microsoft Excel tip will come in handy when you want to create a chart that will
populate your data and highlight only specific parts of that data.

4. The "Non-Relevant" column will return a value if the criteria was not met for the "Relevant"
column.

Download the workbook to practise this exercise.
In the example below, we will look at a grocery store. The chart displays the revenue
generated from the produce department.

5. Create a chart using the "Relevant" and "Non-Relevant" columns. The columns are displayed
in different colours.

If, for example, you wanted to see how Pears compare to Bananas, you could easily
highlight these data points by following the below steps:
1. Add additional columns for "Relevant", "Non-Relevant" and "Criteria".
2. Enter the criteria to be met under the "Criteria" columns, e.g. Bananas and Pears.
3. The "Relevant" column uses an IF(COUNTIF formula to determine if the item meets the
criteria and if so, will return the value.
6. For the chart to display correctly, right click on a data bar and select Format Data Series.
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TIP 2: HOW TO AUTOMATICALLY HIGHLIGHT SPECIFIC DATA USING A BAR CHART
7. From the Format Data Series dialogue box, set the Series Overlap to 100%. As each
produce type has two columns being used in the chart, one with a value and one equal to
0, by overlapping the bars we avoid having an "empty bar" being displayed.

By changing your criteria, the chart is automatically refreshed, and the relevant bars are
highlighted.
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HOW TO CREATE A STEP
CHART

A step chart shows changes that occur over irregular intervals. For example, it can show
stock movement changes, interest rates, etc. A step chart is the perfect alternative to a
line chart as it displays the trend as well as the time taken between changes.

1. The data needs to be reconstructed and set up as follows:
• Copy and paste the headings into new cells.

The difference between a Step Chart and Line Chart: A line chart connects data points
and the focus in such charts is the trend and not the exact time of change. On the other
hand, a step chart shows the exact time of change in the data as well as the trend. With a
step chart, you can easily identify the exact time where there was no change or compare
the extent of change at each instance. In this tip, we will show you how to establish the
trend of a stock item.
Note: Download the sample workbook to practice this exercise.
Steps to create the Step Chart:

• From your dataset, copy the dates starting from the second date and paste in the blank
"Date" column.
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TIP 3: HOW TO CREATE A STEP CHART

From your dataset, copy your sales values starting at the first value to the second last
value, then paste this in the blank "Stock Movement" column.

2. Using this new dataset, select Insert > Charts > Line Chart. Your Step Chart has been created
and is ready for any formatting required.

Copy your original data table and paste it directly underneath the data you have just
copied over into your new columns.
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TO FORMAT A CHART
04 HOW
TO DYNAMICALLY SHOW ITS
MAXIMUM VALUE

Data visualisation is fast becoming the norm for effective business intelligence. Having
visuals that tell the right story at a glance go a long way in achieving this. Microsoft Excel
provides you with a multitude of ways to enhance the visuals that you create. In this tip,
you'll learn how to format a basic bar chart to dynamically highlight the maximum value in
the series.

3. The new series is now added to the chart. You can do this by right clicking on the chart and
choosing Select Data > Select Add from the Select Data Source dialogue, and then pick the
right cells for your series name and series values.

1. Here's a data series showing total sales values for each quarter in the financial year.
A basic bar chart has been created to display this and each bar in the chart has been
widened for greater emphasis. You can achieve this by decreasing the bar gap width
under the Format Data Series options. To get to these options, right click on a bar and
select Format Data Series.

4. The new series is now placed to the right of the existing series. To get it to appear in place of
the existing series you need to overlap it. You can do this by setting the Series Overlap amount
in the chart properties to 100%.
2. To determine the maximum value, another series is added to the chart which is defined
in the column to the right of the total sales. This column uses an IF and MAX function
to return either the total sales value if it is the maximum or else zero. Use the formula
displayed below.
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TIP 4: HOW TO FORMAT A CHART TO DYNAMICALLY SHOW ITS MAXIMUM VALUE

Take note that as your series values change, the chart updates accordingly.

If the highlight isn't displaying, go back to the Select Data Source dialogue and make sure
that your highlight series is positioned after your main values series.

Excel provides a multitude of ways for you to enhance your visuals. By exploring the
possibilities, you're able to display your information in the most effective way for your
needs.
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HOW TO CREATE A SIMPLE
FINANCIAL DASHBOARD

When viewing numerical data in Excel, you may at some point want to represent this data
visually. This gives you the ability to easily analyze large amounts of data. Charts and
graphs also make your report look more professional and can even help when creating
dashboards. In this Excel tip, we will show you how to create a simple financial dashboard.

First, you need to select the data you want the charts to represent.
• Make sure the column headings are also highlighted
• Excel will detect data in the selected cells and find a pattern

We are going to work with data from a simple income statement. We will create two
charts: a waterfall chart and clustered column chart to show the comparison between
the different sections of an income statement (revenue, cost of sales, expenses, gross
profit and net income).
Note: This data can come from anywhere; your Sage solution or from a different
Accounting program or even from a simple Excel spreadsheet.
Here we have an income statement showing the revenue, cost of sales, expenses, gross
profit and net income for the first quarter, as well as the year to date.
Once you have selected your data, do the following:
• From the main menu in Excel, choose Insert. Go to the Charts section. You should see the
chart options. Click on Recommended Charts.

Let insert two charts to give this report a more visual display that is easier to analyze.
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TIP 5: HOW TO CREATE A SIMPLE FINANCIAL DASHBOARD

A window appears showing the available chart types:

The chart has a legend showing the different areas of data represented. The blue columns
represent data for quarter 1 while the grey represents the Year to Date values.

• Choose the first option to insert a clustered column. Clustered column charts are used
to compare values across categories (like between the different sections of an income
statement).

• Click on any of the blue columns. Notice the data selected in the income statement shifts to
just the Q1 column and the corresponding income statement categories (Year to Date is no
longer part of the selection).

Click OK. A chart is now inserted in your spreadsheet.
• Click on the chart. Notice how the data used in the chart is automatically selected and
color coded in the income statement. This shows where the chart is pulling its data
from.
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Now click on any of the grey columns. The year to date column of the income statement
is now selected (Q1 is no longer part of the selection).

The result should look like the following image:
Now, let’s insert a waterfall chart using the same method. These chart types show
running totals for each category. They also show increases and decreases (negatives and
positives) where available.

You have now created a simple financial dashboard showing the income statement for Q1 and
year to date, with two dynamic charts to assist you when analyzing your financial data.
We also have some parameters (year and period) and if those parameters were to change, the
charts will automatically adjust to reflect these changes. No need to recreate the charts!
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HOW TO HIGHLIGHT DATA
POINTS IN AN EXCEL CHART
USING FORM CONTROLS

It's not always easy to trace which data point relates to which series in a chart, especially
when it comes to a line chart. To overcome this problem, we can dynamically highlight an
individual data point. Let’s get started.

• Copy the data pasted on Sheet 2 and paste it directly on top of the chart. Excel inserts
another data series directly over the existing one.

Download the workbook to practice.
• Copy the data and paste it in a different area in your workbook. In our example, we are
copying the range Sheet1!A1:G5 to Sheet 2!A1:G5

• Select the data on Sheet1 and insert a Line Chart With Markers

• Select the Developer Tab > Insert > and select the Option Button (Form Control). Click
anywhere in the worksheet to insert the button.

13

TIP 6: HOW TO HIGHLIGHT DATA POINTS IN A CHART USING FORM CONTROLS

• Right click on the button and select Format Control.

• Ensure the buttons are working correctly by selecting each one and checking that the value
in M2 changes with each selection.

• In the Cell Link box enter the cell you want to connect to this button. In our example I
have entered M2. Select OK.

• Enter a 1 in N2, 2 in N3, etc until you have the desired number of entries.

• In cell O2 enter the formula =$M$2=N2 and drag the fill handle down to the last cell

• On Sheet 2, enter the following formula in cell B2 =IF(Sheet1!$O2=TRUE,Sheet1!B2,NA())
• Drag the fill handle down to cell B5 and then again across all the columns to column G.
• Repeat the above process until you have the desired number of buttons and link them
all to the same cell. In our example we will need 4 buttons for each year. Edit the
button label to the correct annotation.
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TIP 6: HOW TO HIGHLIGHT DATA POINTS IN A CHART USING FORM CONTROLS

• Click the 2016 button and right click on the relevant data series in the chart. Click
Format data series.

- Dash Type : Dash

• Make the following changes to the line and marker:
- Fill : No line

• Repeat the above process on the remaining data series.
• Edit the chart elements by clicking them and either deleting them or editing them e.g. chart
title, gridlines etc.

- Marker : Size 15

• As the years are represented by the Option buttons, the legend can be deleted.

- Fill : No Fill
- Border : Colour = Red
- Border : Width = 1.5pt
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TIP 6: HOW TO HIGHLIGHT DATA POINTS IN A CHART USING FORM CONTROLS

Note: if you do not see the Developer Tab, follow the steps below:
To display the DEVELOPER tab, click on the File menu and then select Options from the
drop-down menu.

Now you should see the DEVELOPER tab in the toolbar at the top of the screen.

When the Excel Options window appears, click on the Customize Ribbon option on the
left. Click on the Developer checkbox under the list of Main Tabs on the right. Then click
on the OK button.
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ENJOYED THE HANDY TIPS AND TRICKS IN THIS E-BOOK?

This e-book is a just taste of how we can help you to maximize your investment in Sage Intelligence Reporting so you can gain meaningful
insights into your data to give your company a competitive edge. Check out the following learning and resources to help you better report on
your business's financials.

Sage Intelligence Learning Portal

Your personal library of learning resources that suits your knowledge level, and then guides you towards mastering your
solution!

Visit the Sage Intelligence Learning Portal
Subscribe to our Tips and Tricks Newsletter

Join over 20 000 subscribers to our popular Sage Intelligence and Excel tips and tricks and get a handy tip delivered monthly
straight to your inbox!

Subscribe to Excel tips & tricks
Subscribe to Sage Intelligence tips & tricks
Get FREE additional reports.

Have reports to create, but no time to create them? We’ve got you covered! With a suite of additional reports available for you
to access at anytime from anywhere, you’ll have more time to run and manage your business and do what you love!

Find out more

www.sageintelligence.com
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