EMAIL PROGRAM NOT MAPI COMPATIBLE ?? BUT IT IS

I know this topic has come up many times and I have read over them and made appropriate changes but I still cannot get my Sage 50 Canadian edition to interface with my Outlook 2013 (32 bit!).

The following message comes us

Sage 50 cannot communicate with your email program.  Please ensure that your email program is MAPI-compatible and this it is the default MAPI client.
I have gone into the sage 50 program in control panel and unchecked/check the sage add-in.  Ensured the add-in is in outlook.  My Outlook is not click to run.  All programs are up to date.  Aaarrgh! 
Any suggestions?
Thanks!!!!

Parents Reply Children
  • if I open outlook from another program Norton will ask me if I would like to allow it

    And when you try to email from Sage 50, you get nothing from Norton?  

    What happens if you disable the Norton firewall for 15 minutes and try?

  • Randy, your link opens Outlook 2013 for me too, but I get the same error emailing with Sage

    but I can email using Quickbooks - so it can't be a firewall issue

    to be sure, I disabled the firewall and tried Sage again - same error

    but when I open outlook, I get

      sage 50 add-in

      the parameter is incorrect

    what parameter ?

    I click ok, and outlook opens

  • Open Control Panel, right-click on Sage 50

    Do a 'change' installation of Sage 50, and un-check the Add-In for Outlook, then do another 'change' installation of Sage 50, and select it to install.

    It can still be an anti-malware / firewall issue if you can email from one program, and not another, since the antimalware / firewall software may be configured to block some programs, and not others.  

    I've seen Norton silently block Sage 50 from connecting to data on another workstation, opening the firewall for 15 minutes made everything work.  Then came the fun process of configuring Norton...

    Panda was especially certain that Sage 50 was evil for trying to connect to anything.  I had to completely uninstall it and use Windows Defender.

    So, yes, anti-malware isn't an excuse from a support tech.  If all the software is installed, all the wiring is hooked up, and it still doesn't work, it's the most probable cause of an issue.

  • reinstalling the feature fixed the add-in problem, there is now a second option on the outlook ribbon - menu commands  and the sync option seems to work

    but sending an email to [email protected] still produces the mapi error

    this is after disabling the windows firewall and AVG antivirus

    more testing to be done

  • There are other possible fixes in this thread, including installing Mozilla Thunderbird (?):

    http://sagecity.na.sage.com/support_communities/sage_50_accounting_ca/f/160/t/69316.aspx

    There are some possibly applicable fixes in this thread for another software product:

    http://www.wellspringsoftware.com/forum/messages.aspx?TopicID=417

    Running FixMAPI may work, or checking that the registry key is there may also work, but it also may require what they did - change their software to finally fix the issue, for a ''few of their clients''.

    If you've tried everything else suggested here and in the knowledgebase, it may be time to open a support ticket with Sage.